blob: cbc1fd89c69c1f6db301b7136e2edb4b716fbef5 [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c"
CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "4d4c80670cea6d1ce2091e03a258966f44f6e859" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE="common-mk pwgtocanonij .gn"
CROS_WORKON_OUTOFTREE_BUILD=1
PLATFORM_SUBDIR="pwgtocanonij"
inherit cros-workon platform
DESCRIPTION="Canon print filters for CUPS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/pwgtocanonij/"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="net-print/cups"
DEPEND="${RDEPEND}"
src_install() {
exeinto /usr/libexec/cups/filter
doexe "${OUT}"/pwgtocanonij
}
platform_pkg_test() {
platform test_all
}