blob: ec3590bbc20ae0bcd11120f4be7e1caaba867130 [file] [log] [blame]
# Copyright 2012 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c"
CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "466d46556e26af1d31a5e30f9001eb07fa4ad00c" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_REPO="${CROS_GIT_HOST_URL}"
#CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk verity .gn"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_EGIT_BRANCH="main"
PLATFORM_SUBDIR="verity"
inherit cros-workon platform
DESCRIPTION="File system integrity image generator for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/verity/"
LICENSE="BSD-Google GPL-2"
KEYWORDS="*"
PATCHES=(
"${FILESDIR}/support-new-dm-verity-format.patch"
"${FILESDIR}/0001-Add-version-to-PrintTable-and-GetTable.patch"
)
src_install() {
platform_src_install
}
platform_pkg_test() {
platform test_all
}