blob: b930e951615e1917bf04aceb3c87f71e481bba7c [file] [log] [blame]
# Copyright 2023 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_PROJECT=(
"chromiumos/platform2"
"chromiumos/platform/redaction_tool"
)
CROS_WORKON_LOCALNAME=(
"platform2"
"platform/redaction_tool"
)
CROS_WORKON_DESTDIR=(
"${S}/platform2"
# This needs to be platform2/redaction_tool instead of
# platform/redaction_tool because we are using the
# platform2 build system.
"${S}/platform2/redaction_tool"
)
CROS_WORKON_SUBTREE=("common-mk metrics .gn" "")
PLATFORM_SUBDIR="redaction_tool"
inherit cros-workon platform
DESCRIPTION="Redaction tool library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/redaction_tool"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
IUSE="+cpp20"
COMMON_DEPEND="
chromeos-base/metrics:=
dev-libs/re2:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="
${COMMON_DEPEND}
chromeos-base/session_manager-client
"
platform_pkg_test() {
platform test_all
}