blob: 3dd94c956e4449f14ee3e272b97199599da3ec5c [file] [log] [blame]
# Copyright 2023 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("8b6e11a069e490c761cdab7ab3ff59434806cd9c" "652894ea880dfd0ed451f1bc16e4e428722c281b")
CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "faa5b8036561b66b5b9d79ea1af8a95927a0ae0f" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6" "2f42cfffa985d335548d2016894f5b790e46bc56")
CROS_WORKON_PROJECT=(
"chromiumos/platform2"
"chromiumos/platform/redaction_tool"
)
CROS_WORKON_LOCALNAME=(
"platform2"
"platform/redaction_tool"
)
CROS_WORKON_DESTDIR=(
"${S}/platform2"
# This needs to be platform2/redaction_tool instead of
# platform/redaction_tool because we are using the
# platform2 build system.
"${S}/platform2/redaction_tool"
)
CROS_WORKON_SUBTREE=("common-mk metrics .gn" "")
PLATFORM_SUBDIR="redaction_tool"
inherit cros-workon platform
DESCRIPTION="Redaction tool library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/redaction_tool"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="+cpp20"
COMMON_DEPEND="
chromeos-base/metrics:=
dev-libs/re2:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="
${COMMON_DEPEND}
chromeos-base/session_manager-client
"
platform_pkg_test() {
platform test_all
}