blob: 9da48edb76e21f04fab9023959ac2e86955ec16c [file] [log] [blame]
# Copyright 2021 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("8b6e11a069e490c761cdab7ab3ff59434806cd9c" "41f3c0b526d4929ea3e54786908041ba0a7e8e2a")
CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6" "3e7b8bfb952f5efc1dcf217ebbd0a1e01374ca9c")
inherit cros-constants
CROS_WORKON_LOCALNAME=(
"platform2"
"platform/pinweaver"
)
CROS_WORKON_PROJECT=(
"chromiumos/platform2"
"chromiumos/platform/pinweaver"
)
CROS_WORKON_OPTIONAL_CHECKOUT=(
"true"
"true"
)
CROS_WORKON_DESTDIR=(
"${S}/platform2"
"${S}/platform2/pinweaver"
)
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE=(
"common-mk .gn"
""
)
PLATFORM_SUBDIR="pinweaver"
inherit cros-workon platform
DESCRIPTION="PinWeaver code that can be used across implementation platforms."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/pinweaver/+/main/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="fuzzer"
RDEPEND=""
DEPEND="${RDEPEND}"
src_install() {
platform_src_install
dolib.a "${OUT}"/libpinweaver.a
insinto /usr/include/pinweaver
doins eal/tpm_storage/pinweaver_eal_types.h
doins pinweaver.h
doins pinweaver_eal.h
doins pinweaver_types.h
local fuzzer_component_id="1188704"
platform_fuzzer_install "${S}"/OWNERS \
"${OUT}"/pinweaver_fuzzer \
--comp "${fuzzer_component_id}"
}