blob: 9cd52010c77b0ffda7e4e20041bd20b9f6e6cd13 [file] [log] [blame]
# Copyright 2013 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
CROS_WORKON_COMMIT="ed43cb5a26abe0d730a1c6dc79af15d28dab7899"
CROS_WORKON_TREE="1592e5cc519366f2c0226f13594017da4a5f5a47"
CROS_WORKON_PROJECT="chromiumos/platform/mttools"
CROS_WORKON_LOCALNAME="platform/mttools"
inherit cros-sanitizers cros-workon cros-common.mk cros-constants cros-debug
DESCRIPTION="Chromium OS multitouch utilities"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/mttools"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan"
# This package has no tests.
RESTRICT="test"
RDEPEND="chromeos-base/gestures
app-misc/utouch-evemu
chromeos-base/libevdev:=
chromeos-base/touch_firmware_test"
DEPEND=${RDEPEND}
src_configure() {
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
# install to autotest deps directory for dependency
emake DESTDIR="${D}${AUTOTEST_BASE}/client/deps/touchpad-tests/framework" install
}