blob: 36ab34742d0b9b905979fe2d7ac53b3d0dadf2fa [file] [log] [blame]
# Copyright 2020 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn"
DESCRIPTION="Chrome OS ML Benchmarking Suite"
PLATFORM_SUBDIR="ml_benchmark"
# Do not run test parallelly until unit tests are fixed.
# shellcheck disable=SC2034
PLATFORM_PARALLEL_GTEST_TEST="no"
inherit cros-workon platform
# chromeos-base/ml_benchmark blocked due to package rename
RDEPEND="
!chromeos-base/ml_benchmark
dev-libs/protobuf:=
dev-libs/re2:=
vulkan? ( media-libs/clvk )
"
DEPEND="${RDEPEND}"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="vulkan"
platform_pkg_test() {
platform test_all
}