blob: 8293bee8be5e455e0d7d23068af15f987f1fd333 [file] [log] [blame]
# Copyright 2023 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c"
CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "88bcc1d39084f5d0a4ca836beaf45c0b55dbc1c3" "3c167588538b9dd3054faa5a301fa17387858e60" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libcrossystem libsegmentation .gn"
PLATFORM_SUBDIR="libsegmentation"
inherit cros-workon platform
DESCRIPTION="Library to get Chromium OS system properties"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libsegmentation"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="feature_management"
COMMON_DEPEND="
chromeos-base/libcrossystem:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
chromeos-base/feature-management-data:=
"
BDEPEND="
dev-libs/protobuf
"
platform_pkg_test() {
platform test_all
}