blob: ecf86e616d04e9f9d70009410bc33225593e3ea8 [file] [log] [blame]
# Copyright 2020 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c"
CROS_WORKON_TREE=("102d4ec63eaf55397c3fc456d3b70e574692dc44" "41d899585b7a07ea908a0cca2944a7b8a4d13655" "351fb08db6b0e98a2c6de16681f05c1876359158" "9dbbe059a64bdb3260dc088895573df5ea421399" "0d9d2046eb78dc8620f7594f245298f9fd964832" "989acbd33fd18024396e010b1be43d25cbdf942d" "f73f25bb045d099841b3ac929b6d3218060216df" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="attestation common-mk hwsec-test-utils libhwsec libhwsec-foundation tpm_manager trunks .gn"
PLATFORM_SUBDIR="hwsec-test-utils"
inherit cros-workon platform
DESCRIPTION="Hwsec-related test-only features. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hwsec-test-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm_dynamic tpm2"
REQUIRED_USE="
tpm_dynamic? ( tpm tpm2 )
!tpm_dynamic? ( ?? ( tpm tpm2 ) )
"
RDEPEND="
tpm? (
app-crypt/trousers:=
)
chromeos-base/attestation:=
chromeos-base/libhwsec:=
chromeos-base/libhwsec-foundation:=
chromeos-base/system_api:=
tpm2? (
chromeos-base/trunks:=
)
dev-libs/openssl:=
dev-libs/protobuf:=
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/trunks:=[test?]
)
"
platform_pkg_test() {
platform test_all
}