blob: 55b271a089473b6e91812219ccc0802b1e52bc8c [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c"
CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "ad0037ea3ece0d38951407fda04d247468b76b23" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk flex_id .gn"
PLATFORM_SUBDIR="flex_id"
inherit cros-workon platform
DESCRIPTION="Utility to generate Flex ID for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/flex_id"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND="!chromeos-base/client_id"
src_install() {
platform_src_install
dobin "${OUT}"/flex_id_tool
}
platform_pkg_test() {
platform_test "run" "${OUT}/flex_id_test"
}