blob: 12a8f46d487166f0593c3cd23796cd8c5cd8f7ea [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b8d3f5f97670e21de947a9a613b06b42bc215030"
CROS_WORKON_TREE=("b087d67fb825144293443ca40ea96e830e5a21f0" "e86faf0104546e30d552a3dfe7b3b8b37d31179e" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="shill/client"
# D-Bus proxy autogenerated headers require libchrome/libbrillo headers.
WANT_LIBCHROME="yes"
WANT_LIBBRILLO="yes"
inherit cros-workon platform
DESCRIPTION="Shill DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/shill/"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND="
!<chromeos-base/shill-0.0.2
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "shill"
}