blob: 37e5e10efc43d9d33f6ce8920fa8dfcbdae100c6 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/confuse-2.7.ebuild,v 1.13 2013/03/01 08:16:02 vapier Exp $
EAPI=3
inherit eutils
DESCRIPTION="a configuration file parser library"
HOMEPAGE="http://www.nongnu.org/confuse/"
SRC_URI="mirror://nongnu/confuse/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="*"
IUSE="nls static-libs"
DEPEND="sys-devel/flex
sys-devel/libtool
virtual/pkgconfig
nls? ( sys-devel/gettext )"
RDEPEND="nls? ( virtual/libintl )"
src_prepare() {
# Upstream commit:
# https://github.com/libconfuse/libconfuse/commit/d73777c2c3566fb2647727bb56d9a2295b81669b
epatch "${FILESDIR}"/confuse-3.3-fix-CVE-2022-40320.patch
}
src_configure() {
# examples are normally compiled but not installed. They
# fail during a mingw crosscompile.
econf \
--enable-shared \
--disable-examples \
$(use_enable nls) \
$(use_enable static-libs static)
}
src_install() {
emake DESTDIR="${D}" install || die
doman doc/man/man3/*.3 || die
dodoc AUTHORS NEWS README || die
dohtml doc/html/* || die
docinto examples
dodoc examples/*.{c,conf} || die
}