blob: 1ad09ff0235bb50c5ca9c1328c86b20bf2cac437 [file] [log] [blame]
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools libtool
DESCRIPTION="YAML 1.1 parser and emitter written in C"
HOMEPAGE="https://github.com/yaml/libyaml"
SRC_URI="https://github.com/yaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE="doc static-libs test"
RESTRICT="!test? ( test )"
DEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
default
# conditionally remove tests
if ! use test; then
sed -i -e 's: tests::g' Makefile* || die
fi
elibtoolize # for FreeMiNT
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
}
src_compile() {
emake
use doc && emake html
}
src_install() {
use doc && HTML_DOCS=( doc/html/. )
default
find "${D}" -name '*.la' -delete || die
}