blob: 15138bbb132fd6f4bdb9055f7133935796bdf51d [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
DESCRIPTION="A Python package for creating beautiful command line interfaces"
SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
IUSE="examples"
RDEPEND="
$(python_gen_cond_dep '
dev-python/importlib_metadata[${PYTHON_USEDEP}]
' python3_6 python3_7 pypy3)"
distutils_enable_sphinx docs \
'>=dev-python/docutils-0.14' \
dev-python/pallets-sphinx-themes \
dev-python/sphinxcontrib-log_cabinet
distutils_enable_tests pytest
python_install_all() {
use examples && dodoc -r examples
distutils-r1_python_install_all
}