blob: 7340212ac3d511370a24e99ef8f25be5ba9a58c9 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson
DESCRIPTION="Wayland protocol files"
HOMEPAGE="https://wayland.freedesktop.org/"
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
inherit git-r3
else
SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
KEYWORDS="*"
fi
LICENSE="MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="
test? ( dev-libs/wayland )
"
RDEPEND=""
BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
"
src_configure() {
local emesonargs=(
$(meson_use test tests)
)
meson_src_configure
}