blob: cab9933516628f47fcb2a23caf2ad5cf2e7ac581 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7,8} pypy{,3} )
inherit distutils-r1
MY_P="path.py-${PV}"
DESCRIPTION="A module wrapper for os.path"
HOMEPAGE="https://pypi.org/project/path.py/ https://github.com/jaraco/path.py"
SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
SLOT="0"
LICENSE="MIT"
KEYWORDS="*"
IUSE="test"
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${MY_P}"
python_prepare_all() {
sed '/setuptools_scm/d' -i setup.py || die
# disable flake8 tests
sed -i 's/ --flake8//' pytest.ini || die
distutils-r1_python_prepare_all
}
python_test() {
PYTHONPATH=. py.test -v || die
}