blob: fc6514f638337885e95dacb7b978114771bc1d7a [file] [log] [blame]
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Parallel bzip2 utility"
HOMEPAGE="https://github.com/kjn/lbzip2/"
SRC_URI="http://archive.lbzip2.org/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="*"
IUSE="debug symlink"
RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
DEPEND=""
PATCHES=(
"${FILESDIR}"/${PN}-2.3-s_isreg.patch
# bug 669594
"${FILESDIR}"/${PN}-2.5-glibc-2.28.patch
)
src_configure() {
local myeconfargs=(
--disable-silent-rules
$(use_enable debug tracing)
)
econf "${myeconfargs[@]}"
}
src_install() {
default
if use symlink; then
dosym ${PN} /usr/bin/bzip2
dosym lbunzip2 /usr/bin/bunzip2
fi
}