| # Copyright 1999-2017 Gentoo Foundation |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=5 |
| AUTOTOOLS_AUTORECONF=1 |
| inherit autotools-multilib |
| |
| DESCRIPTION="The Ogg Vorbis sound file format library" |
| HOMEPAGE="http://xiph.org/vorbis" |
| SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.xz" |
| |
| LICENSE="BSD" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="static-libs" |
| |
| RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] |
| abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )" |
| DEPEND="${RDEPEND} |
| app-arch/xz-utils |
| virtual/pkgconfig" |
| |
| AUTOTOOLS_PRUNE_LIBTOOL_FILES=all |
| |
| src_prepare() { |
| sed -i \ |
| -e '/CFLAGS/s:-O20::' \ |
| -e '/CFLAGS/s:-mcpu=750::' \ |
| -e '/CFLAGS/s:-mno-ieee-fp::' \ |
| configure.ac || die |
| |
| # Un-hack docdir redefinition. |
| find -name 'Makefile.am' \ |
| -exec sed -i \ |
| -e 's:$(datadir)/doc/$(PACKAGE)-$(VERSION):@docdir@/html:' \ |
| {} + || die |
| |
| AT_M4DIR="m4" \ |
| autotools-multilib_src_prepare |
| } |