blob: eae4d87b5089d71f8602c98ded8230b26a20623c [file] [log] [blame]
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit multilib-minimal toolchain-funcs verify-sig
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="
https://www.gnu.org/software/libidn/#libidn2
https://gitlab.com/libidn/libidn2/
"
SRC_URI="
mirror://gnu/libidn/${P}.tar.gz
verify-sig? ( mirror://gnu/libidn/${P}.tar.gz.sig )
"
S="${WORKDIR}"/${P/a/}
LICENSE="|| ( GPL-2+ LGPL-3+ ) GPL-3+ unicode"
SLOT="0/2"
KEYWORDS="*"
IUSE="nls static-libs"
RDEPEND="
dev-libs/libunistring:=[${MULTILIB_USEDEP}]
"
DEPEND="
${RDEPEND}
"
BDEPEND="
dev-lang/perl
nls? ( sys-devel/gettext )
verify-sig? ( sec-keys/openpgp-keys-libidn )
"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libidn.asc
multilib_src_configure() {
local myconf=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(multilib_native_use_enable nls)
--enable-doc
--disable-gcc-warnings
--disable-gtk-doc
--disable-valgrind-tests
)
local ECONF_SOURCE=${S}
econf "${myconf[@]}"
}
multilib_src_install() {
default
find "${ED}" -name '*.la' -delete || die
}