blob: 613192186bc602f51162aaf41ccc2f7ca7855745 [file] [log] [blame]
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.7.1.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
CABAL_HACKAGE_REVISION="2"
inherit haskell-cabal
DESCRIPTION="Type definitions for Universally Unique Identifiers"
HOMEPAGE="https://github.com/haskell-hvr/uuid"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="*"
RDEPEND=">=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
>=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/ghc-byteorder-4.11 <dev-haskell/ghc-byteorder-4.12
>=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
>=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
>=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
>=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
"
BDEPEND="app-text/dos2unix"
src_prepare() {
# pull revised cabal from upstream
cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
# Convert to unix line endings
dos2unix "${S}/${PN}.cabal" || die
# Apply patches *after* pulling the revised cabal
default
}