blob: 5b0228a1ebbf63ee6189dd5eb30b73bf18f3e2cc [file] [log] [blame]
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.7.9999
#hackport: flags: -bytestring-builder,-developer
CABAL_FEATURES="lib profile haddock hoogle hscolour" # circular deps in test-suite
# break circular dependencies:
# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
CABAL_FEATURES+=" nocabaldep"
inherit haskell-cabal
DESCRIPTION="An efficient packed Unicode text type"
HOMEPAGE="https://github.com/haskell/text"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/${PV}"
#keep in sync with ghc-9.0.2
KEYWORDS="*"
# break cyclic dependencies:
RESTRICT=test
RDEPEND=">=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}"
src_configure() {
haskell-cabal_src_configure \
--flag=-bytestring-builder \
--flag=-developer
}
CABAL_CORE_LIB_GHC_PV="9.0.2"