blob: 7b8fd123caf4674872d66aa8cb17cf29904d71cf [file] [log] [blame]
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.7.1.1.9999
#hackport: flags: +clock,+unix
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Modern and extensible testing framework"
HOMEPAGE="https://github.com/UnkindPartition/tasty"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="*"
RDEPEND=">=dev-haskell/ansi-terminal-0.9:=[profile?]
>=dev-haskell/clock-0.4.4.0:=[profile?]
>=dev-haskell/optparse-applicative-0.14:=[profile?]
>=dev-haskell/stm-2.3:=[profile?]
>=dev-haskell/tagged-0.5:=[profile?]
>=dev-haskell/unbounded-delays-0.1:=[profile?]
dev-haskell/wcwidth:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
--flag=clock \
--flag=unix
}