blob: 27ba8a5c4471c933e766338c11a0e8b0192b6ac7 [file] [log] [blame]
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..12} )
inherit distutils-r1 pypi
DESCRIPTION="Python Serial Port extension"
HOMEPAGE="
https://github.com/pyserial/pyserial/
https://pypi.org/project/pyserial/
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
IUSE="examples"
DOCS=( CHANGES.rst README.rst )
distutils_enable_sphinx documentation --no-autodoc
python_test() {
"${EPYTHON}" test/run_all_tests.py loop:// -v ||
die "Testing failed with ${EPYTHON}"
}
python_install_all() {
distutils-r1_python_install_all
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}