blob: eb0847482cf88e716104ad70b488a4f4b71c1074 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
if [[ ${PV} != 3.2.3 ]]; then
# Make sure we revert the autotools hackery applied in 3.2.3.
die "Please use rsync-9999.ebuild as a basis for version bumps"
fi
WANT_LIBTOOL=none
inherit autotools prefix systemd
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
SRC_DIR="src"
KEYWORDS="*"
SRC_URI="https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz"
S="${WORKDIR}/${P/_/}"
LICENSE="GPL-3"
SLOT="0"
IUSE="acl examples iconv ipv6 lz4 ssl stunnel system-zlib xattr xxhash zstd"
RDEPEND="acl? ( virtual/acl )
lz4? ( app-arch/lz4 )
ssl? ( dev-libs/openssl:0= )
system-zlib? ( sys-libs/zlib )
xattr? ( kernel_linux? ( sys-apps/attr ) )
xxhash? ( dev-libs/xxhash )
zstd? ( >=app-arch/zstd-1.4 )
>=dev-libs/popt-1.5
iconv? ( virtual/libiconv )"
DEPEND="${RDEPEND}"
src_prepare() {
local PATCHES=(
"${FILESDIR}/${P}-glibc-lchmod.patch"
"${FILESDIR}/${P}-cross.patch"
# Fix for (CVE-2020-14387) - net-misc/rsync: improper TLS validation in rsync-ssl script
"${FILESDIR}/${P}-verify-certificate.patch"
)
default
eautoconf -o configure.sh
touch config.h.in || die
}
src_configure() {
local myeconfargs=(
--with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
--without-included-popt
$(use_enable acl acl-support)
$(use_enable iconv)
$(use_enable ipv6)
$(use_enable lz4)
$(use_enable ssl openssl)
$(use_with !system-zlib included-zlib)
$(use_enable xattr xattr-support)
$(use_enable xxhash)
$(use_enable zstd)
)
econf "${myeconfargs[@]}"
}
src_install() {
emake DESTDIR="${D}" install
newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
dodoc NEWS.md README.md TODO tech_report.tex
insinto /etc
newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
insinto /etc/logrotate.d
newins "${FILESDIR}"/rsyncd.logrotate rsyncd
insinto /etc/xinetd.d
newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
# Install stunnel helpers
if use stunnel ; then
emake DESTDIR="${D}" install-ssl-daemon
fi
# Install the useful contrib scripts
if use examples ; then
exeinto /usr/share/rsync
doexe support/*
rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
fi
eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
systemd_newunit "packaging/systemd/rsync.service" "rsyncd.service"
}
pkg_postinst() {
if grep -Eqis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
"${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
ewarn "You have disabled chroot support in your rsyncd.conf. This"
ewarn "is a security risk which you should fix. Please check your"
ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
fi
if use stunnel ; then
einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
einfo
einfo "You maybe have to update the certificates configured in"
einfo "${EROOT}/etc/stunnel/rsync.conf"
fi
if use system-zlib ; then
ewarn "Using system-zlib is incompatible with <rsync-3.1.1 when"
ewarn "using the --compress option."
ewarn
ewarn "When syncing with >=rsync-3.1.1 built with bundled zlib,"
ewarn "and the --compress option, add --new-compress (-zz)."
ewarn
ewarn "For syncing the portage tree, add:"
ewarn "PORTAGE_RSYNC_EXTRA_OPTS=\"--new-compress\" to make.conf"
fi
}