blob: 612ae07533ec4dfadb6cbab1a07ab10c38147792 [file] [log] [blame]
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson-multilib
DESCRIPTION="inih (INI not invented here) simple .INI file parser"
HOMEPAGE="https://github.com/benhoyt/inih"
SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="*"
LICENSE="BSD"
SLOT="0"
IUSE="static-libs"
S="${WORKDIR}/inih-r${PV}"
multilib_src_configure() {
local emesonargs=(
-Ddefault_library=$(usex static-libs both shared)
-Ddistro_install=true
-Dwith_INIReader=true
)
meson_src_configure
}
multilib_src_install_all() {
local DOCS=(
LICENSE.txt
README.md
)
einstalldocs
}