blob: 1f5b87621ac7b90c0a50f4ad938e9e0cc8a72643 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 flag-o-matic
DESCRIPTION="Alternative regular expression module to replace re"
HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE="doc"
distutils_enable_tests unittest
python_test() {
eunittest -s "${BUILD_DIR}"/lib
}
python_install_all() {
use doc && local HTML_DOCS=( docs/Features.html )
local DOCS=( README.rst docs/*.rst )
distutils-r1_python_install_all
}