blob: 4e769a4d6c48b7cb316fd23bda865e8d93e346c5 [file] [log] [blame]
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic multilib-minimal toolchain-funcs verify-sig
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="
https://www.gnu.org/software/libidn/#libidn2
https://gitlab.com/libidn/libidn2/
"
SRC_URI="
mirror://gnu/libidn/${P}.tar.gz
verify-sig? ( mirror://gnu/libidn/${P}.tar.gz.sig )
"
S="${WORKDIR}"/${P/a/}
LICENSE="GPL-2+ LGPL-3+"
SLOT="0/2"
KEYWORDS="*"
IUSE="nls static-libs"
RDEPEND="
dev-libs/libunistring:=[${MULTILIB_USEDEP}]
"
DEPEND="
${RDEPEND}
"
BDEPEND="
dev-lang/perl
sys-apps/help2man
nls? ( sys-devel/gettext )
verify-sig? ( sec-keys/openpgp-keys-libidn )
"
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libidn.asc
multilib_src_configure() {
# ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
# https://github.com/gentoo/gentoo/pull/28355
# mold needs this too but right now tc-ld-is-mold is also not available
if tc-ld-is-lld; then
append-ldflags -Wl,--undefined-version
fi
local myconf=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(multilib_native_use_enable nls)
--disable-doc
--disable-gcc-warnings
--disable-gtk-doc
)
local ECONF_SOURCE=${S}
econf "${myconf[@]}"
}
multilib_src_install() {
default
find "${ED}" -name '*.la' -delete || die
}