blob: a5aac4fffd119a54c2c28688fd4ad75d246f9351 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
DESCRIPTION="Python 2 and 3 compatibility library"
HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
distutils_enable_sphinx documentation --no-autodoc
distutils_enable_tests pytest
python_test() {
local deselect=()
[[ ${EPYTHON} == pypy3 ]] && deselect+=(
'test_six.py::test_move_items[dbm_ndbm]'
)
epytest ${deselect[@]/#/--deselect }
}