blob: 3f5d94cc01572f772e447f7bb719ec80153a2517 [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7,8} pypy )
inherit distutils-r1
DESCRIPTION="Simple generic functions for Python"
HOMEPAGE="https://pypi.org/project/simplegeneric/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND="
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
python_test() {
esetup.py test
}