blob: 0ae692ace8049e5f1c77b01be0af9b83bde57852 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7
DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{8..9} pypy3 )
inherit distutils-r1
DESCRIPTION="Core utilities for Python packages"
HOMEPAGE="
https://github.com/pypa/packaging/
https://pypi.org/project/packaging/"
SRC_URI="
https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
SLOT="0"
LICENSE="|| ( Apache-2.0 BSD-2 )"
KEYWORDS="*"
RDEPEND="
>=dev-python/pyparsing-3.0.7-r1[${PYTHON_USEDEP}]
"
DEPEND="
test? (
dev-python/pretend[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
src_configure() {
# write a custom pyproject.toml to ease setuptools bootstrap
cat > pyproject.toml <<-EOF || die
[build-system]
requires = ["flit_core >=3.2,<4"]
build-backend = "flit_core.buildapi"
[project]
name = "packaging"
dynamic = ["version"]
description = "More routines for operating on iterables, beyond itertools"
EOF
}
python_test() {
epytest --capture=no
}