blob: 78c6e70180834ef54e82d1e7a90693c73f715bbf [file] [log] [blame]
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{6..9} pypy )
inherit distutils-r1
DESCRIPTION="Python CRC Generator module"
HOMEPAGE="http://crcmod.sourceforge.net/"
SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE=""
DOCS=( changelog test/examples.py )
python_test() {
"${PYTHON}" test/test_crcmod.py || die "Tests fail with ${EPYTHON}"
}