blob: 85828ddb4c2c4955d2f6b362177f6978933efbc7 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6..9} pypy3 )
if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/libsndfile/libsndfile.git"
else
SRC_URI="https://github.com/libsndfile/libsndfile/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="*"
fi
inherit python-any-r1 multilib-minimal
DESCRIPTION="C library for reading and writing files containing sampled sound"
HOMEPAGE="https://libsndfile.github.io/libsndfile/"
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="alsa minimal sqlite test"
RESTRICT="!test? ( test )"
RDEPEND="
!minimal? (
media-libs/flac:=[${MULTILIB_USEDEP}]
media-libs/libogg:=[${MULTILIB_USEDEP}]
media-libs/libvorbis:=[${MULTILIB_USEDEP}]
media-libs/opus:=[${MULTILIB_USEDEP}]
media-sound/lame:=[${MULTILIB_USEDEP}]
media-sound/mpg123:=[${MULTILIB_USEDEP}]
)
alsa? ( media-libs/alsa-lib:= )
sqlite? ( dev-db/sqlite )"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
test? ( ${PYTHON_DEPS} )"
if [[ ${PV} == *9999 ]]; then
BDEPEND+="
${PYTHON_DEPS}
sys-devel/autogen
"
fi
pkg_setup() {
if use test || [[ ${PV} == *9999 ]]; then
python-any-r1_pkg_setup
fi
}
src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
}
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-octave \
--disable-static \
--disable-werror \
$(use_enable !minimal external-libs) \
$(use_enable !minimal mpeg) \
$(multilib_native_enable full-suite) \
$(multilib_native_use_enable alsa) \
$(multilib_native_use_enable sqlite) \
PYTHON="${EPYTHON}"
}
multilib_src_install_all() {
einstalldocs
# no static archives
find "${ED}" -name '*.la' -delete || die
}