blob: b5fa2bab0831e255eec19e7883e75299dcbb490f [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit multilib-minimal
DESCRIPTION="The Ogg media file format library"
HOMEPAGE="https://xiph.org/ogg/"
SRC_URI="https://downloads.xiph.org/releases/ogg/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
IUSE="static-libs"
PATCHES=(
"${FILESDIR}"/${PN}-1.3.4-libdir-m4.patch
)
MULTILIB_WRAPPED_HEADERS=(
/usr/include/ogg/config_types.h
)
multilib_src_configure() {
ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
}
multilib_src_install_all() {
einstalldocs
find "${ED}" -type f -name "*.la" -delete || die
}