blob: b2f84d7a5b08b005faff036113255fe0de3e8af4 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
inherit git-r3
else
SRC_URI="https://wayland.freedesktop.org/releases/wayland-${PV}.tar.xz"
KEYWORDS="*"
S="${WORKDIR}/wayland-${PV}"
fi
inherit meson
DESCRIPTION="wayland-scanner tool"
HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
LICENSE="MIT"
SLOT="0"
BDEPEND="virtual/pkgconfig"
RDEPEND="
!<dev-libs/wayland-${PV}
>=dev-libs/expat-2.1.0-r3:=
"
DEPEND="${RDEPEND}"
src_configure() {
local emesonargs=(
-Ddocumentation=false
-Ddtd_validation=false
-Dlibraries=false
-Dscanner=true
-Dtests=false
)
meson_src_configure
}
src_install() {
meson_src_install
mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/share/pkgconfig
}