blob: 675aef0371ff3fcbe9b2b96273177048965e9a47 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NB: The $PV tracks the *repo launcher version*, not the last signed release
# of the repo project. The launcher only gets a new update when changes are
# made in it.
EAPI="7"
PYTHON_COMPAT=( python3_{6..9} )
inherit python-r1
DESCRIPTION="Google tool for managing git, particularly multiple repos"
HOMEPAGE="https://gerrit.googlesource.com/git-repo"
SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
!app-admin/radmind
!dev-util/repo"
# The git-repo-downloads bucket is controlled by us.
RESTRICT="nomirror"
S=${WORKDIR}
src_install() {
python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
}