| # Copyright 1999-2010 Gentoo Foundation |
| # Distributed under the terms of the GNU General Public License v2 |
| # $Header: /var/cvsroot/gentoo-x86/media-libs/libsamplerate/libsamplerate-0.1.7.ebuild,v 1.10 2010/01/31 16:05:00 armin76 Exp $ |
| |
| inherit eutils autotools |
| |
| DESCRIPTION="Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio" |
| HOMEPAGE="http://www.mega-nerd.com/SRC/" |
| SRC_URI="http://www.mega-nerd.com/SRC/${P}.tar.gz" |
| |
| LICENSE="GPL-2" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="sndfile" |
| |
| RDEPEND="sndfile? ( >=media-libs/libsndfile-1.0.2 )" |
| DEPEND="${RDEPEND} |
| >=dev-util/pkgconfig-0.14" |
| |
| src_unpack() { |
| unpack ${A} |
| cd "${S}" |
| epatch "${FILESDIR}"/${PN}-0.1.3-dontbuild-tests-examples.patch |
| epatch "${FILESDIR}"/${P}-macro-quoting.patch |
| epatch "${FILESDIR}"/${P}-tests.patch |
| eautoreconf |
| } |
| |
| src_compile() { |
| econf \ |
| --disable-fftw \ |
| $(use_enable sndfile) \ |
| --disable-dependency-tracking |
| emake || die |
| } |
| |
| src_install() { |
| emake DESTDIR="${D}" install || die "make install failed" |
| dodoc AUTHORS ChangeLog NEWS README |
| dohtml doc/*.html doc/*.css doc/*.png |
| } |