blob: 6b8bc20e0a7fe269709efd00f090f9926306954c [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
# of the repo project. The launcher only gets a new update when changes are
# made in it.
EAPI="7"
PYTHON_COMPAT=( python3_{6..9} )
inherit bash-completion-r1 python-r1
DESCRIPTION="Google tool for managing git, particularly multiple repos"
HOMEPAGE="https://gerrit.googlesource.com/git-repo"
SRC_URI="https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
!app-admin/radmind
!dev-util/repo"
S="${WORKDIR}/git-${P}"
src_install() {
python_foreach_impl python_doscript ${PN}
newbashcomp completion.bash ${PN}
doman man/*.[0-9]
}