blob: b7534c543d38afdb229e2fa38b4f73bcf87d6357 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/sed.asc
inherit flag-o-matic verify-sig
DESCRIPTION="Super-useful stream editor"
HOMEPAGE="http://sed.sourceforge.net/"
SRC_URI="mirror://gnu/sed/${P}.tar.xz"
SRC_URI+=" verify-sig? ( mirror://gnu/sed/${P}.tar.xz.sig )"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="*"
IUSE="acl nls selinux static"
RDEPEND="
!static? (
acl? ( virtual/acl )
nls? ( virtual/libintl )
selinux? ( sys-libs/libselinux )
)
"
DEPEND="${RDEPEND}
static? (
acl? ( virtual/acl[static-libs(+)] )
nls? ( virtual/libintl[static-libs(+)] )
selinux? ( sys-libs/libselinux[static-libs(+)] )
)
"
BDEPEND="nls? ( sys-devel/gettext )
verify-sig? ( sec-keys/openpgp-keys-sed )"
src_configure() {
use static && append-ldflags -static
local myconf=(
--exec-prefix="${EPREFIX}"
$(use_enable acl)
$(use_enable nls)
$(use_with selinux)
# rename to gsed for better BSD compatibility
--program-prefix=g
)
econf "${myconf[@]}"
}
src_install() {
default
# symlink to the standard name
dosym gsed /bin/sed
dosym gsed.1 /usr/share/man/man1/sed.1
}