blob: d72fbfc7746ed48a4a276b3f95cf1ab1709fa549 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{8..9} pypy3 )
inherit distutils-r1
MY_P=${P/-/_}
DESCRIPTION="Backported and Experimental Type Hints for Python 3.7+"
HOMEPAGE="
https://pypi.org/project/typing-extensions/
https://github.com/python/typing_extensions/
"
SRC_URI="
https://github.com/python/typing_extensions/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="*"
python_test() {
cd "${S}"/src || die
"${EPYTHON}" test_typing_extensions.py -v || die "tests failed under ${EPYTHON}"
}