blob: 75afc370834ff3306d0c24833f58c43b0f50f375 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="USB support for Python"
HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
### This version is compatible with both 0.X and 1.X versions of libusb
RDEPEND="virtual/libusb:="
DEPEND="
${RDEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
"
DOCS=( README.rst docs/tutorial.rst )
python_test() {
cd tests || die
"${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
}