blob: df606f72a2c56008f1cd4f38637aeb7c45593137 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{6..9} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="World timezone definitions for Python"
HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
|| ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
DEPEND="${RDEPEND}
app-arch/unzip"
PATCHES=(
# Use timezone-data zoneinfo.
"${FILESDIR}"/2018.4-zoneinfo.patch
# ...and do not install a copy of it.
"${FILESDIR}"/${PN}-2018.4-zoneinfo-noinstall.patch
)
python_test() {
"${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
}