blob: 5462a37ed8b1cf4531a0e9823b19b1975197c351 [file] [log] [blame]
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7
DISTUTILS_USE_PEP517=no
PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit distutils-r1
DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
HOMEPAGE="
https://pypi.org/project/gpep517/
https://github.com/projg2/gpep517/
"
SRC_URI="
https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
RDEPEND="
>=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
>=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
python_install() {
python_domodule gpep517
python_newscript - gpep517 <<-EOF
#!${EPREFIX}/usr/bin/python
import sys
from gpep517.__main__ import main
sys.exit(main())
EOF
}