blob: a7d031422008fd8a5ffd3f7eb88edd0faaaeaecc [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "9487cb70b8720982545a04ade6a4f464cdde53ac" "509fcdecd3a70e50e5aa4e48d65de2dbd6decdb9" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk feature_usage metrics .gn"
PLATFORM_SUBDIR="feature_usage"
inherit cros-workon platform
DESCRIPTION="Provides a unified approach to report feature usage events"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND="
chromeos-base/metrics:=
"
DEPEND="
${RDEPEND}
"
src_install() {
# Install the static library
dolib.a "${OUT}"/libfeature_usage_static.a
# Install the header
insinto "/usr/include/feature_usage"
doins feature_usage_metrics.h
# Install the pc file
insinto "/usr/$(get_libdir)/pkgconfig"
doins "${OUT}/obj/feature_usage/libfeature_usage.pc"
}
platform_pkg_test() {
platform test_all
}