blob: c834e9cdca55682e51664c17eade65e486d2ee1b [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="8db79520df03dd8595f8c434313b16f4fbebdaa3"
CROS_WORKON_TREE=("d2978748a9dae1dff9440dc2876629c43ee019ee" "06204a3c9728b9f81c708a49e0eab48830b29f04" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk power_manager .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="power_manager/client"
inherit cros-workon platform
DESCRIPTION="Power manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/power_manager/"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND=""
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "power_manager"
}