blob: 9b451ae16223615498c189b3901c7c0268f667c6 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="97f5d3a696dbbd15847d2e23692290c9b43dcffe"
CROS_WORKON_TREE="e2c200b37b72780b72fd07a23555aedf104222cf"
PYTHON_COMPAT=( python3_{6..9} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon python-any-r1
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_unpack() {
cros-workon_src_unpack
S+="/client/site_tests/platform_ToolchainTests/src"
}
src_test() {
einfo "Testing llvm-profdata..."
"${FILESDIR}/llvm-profdata-test.py" || die
default
}