blob: 34c1a4141913879917ab904f89d121e2d09b2aec [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("c142078820d0707858873cedb290a78d36f531af" "52bb3b88cb2dcf59cdcf3612c73987ed685117b5")
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "4dbd9e89c7ca47951c04bf59942d59cb083d1d0e")
CROS_WORKON_PROJECT=("chromiumos/platform2" "chromiumos/platform/tast-tests")
CROS_WORKON_LOCALNAME=("platform2" "platform/tast-tests")
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/tast-tests")
CROS_WORKON_SUBTREE=("common-mk .gn" "helpers")
PLATFORM_SUBDIR="tast-tests/helpers/local"
inherit cros-workon platform
DESCRIPTION="Compiled executables used by local Tast tests in the cros bundle"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/+/master/helpers"
LICENSE="BSD-Google GPL-3"
SLOT="0/0"
KEYWORDS="*"
COMMON_DEPEND="
dev-cpp/gtest:=
media-libs/minigbm:=
x11-libs/libdrm:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${RDEPEND}"
src_install() {
# Executable files' names take the form <category>.<TestName>.<bin_name>.
exeinto /usr/libexec/tast/helpers/local/cros
doexe "${OUT}"/*.[A-Z]*.*
# Install symbol list file to the location required by minidump_stackwalk.
# See https://www.chromium.org/developers/decoding-crash-dumps for details.
local crasher_exec="${OUT}/platform.UserCrash.crasher"
local id=$(head -n1 "${crasher_exec}.sym" | cut -d' ' -f 4)
insinto "/usr/libexec/tast/helpers/local/cros/symbols/${crasher_exec##*/}/${id}"
doins "${crasher_exec}.sym"
}