| # Copyright (c) 2010 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT="6f6efdc6fa38ed3bcacfa9e152f415d50ee8bad0" |
| CROS_WORKON_TREE="06c3486af100c39ddc9cb59381d087b4f2ed1634" |
| CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference" |
| |
| inherit cros-workon autotest |
| |
| DESCRIPTION="TPM firmware tests" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/vboot_reference/" |
| SRC_URI="" |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="*" |
| DEPEND=" |
| app-crypt/trousers:= |
| chromeos-base/tpm:= |
| " |
| |
| # Enable autotest by default. |
| IUSE="${IUSE} +autotest" |
| |
| IUSE_TESTS=" |
| +tests_hardware_TPMFirmware |
| +tests_hardware_TPMFirmwareServer |
| " |
| |
| IUSE="${IUSE} ${IUSE_TESTS}" |
| |
| CROS_WORKON_LOCALNAME=vboot_reference |
| |
| # path from root of repo |
| AUTOTEST_CLIENT_SITE_TESTS=autotest/client |
| AUTOTEST_SERVER_SITE_TESTS=autotest/server |
| |
| function src_compile { |
| # for Makefile |
| export VBOOT_DIR=${WORKDIR}/${P} |
| export MINIMAL=1 # Makefile requires this for cross-compiling |
| autotest_src_compile |
| } |
| |
| |