blob: e442f6d4a1a69db55caa9b7a32728aa1979980c4 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("b05e4a6b92b2cfe608b6cd8d5d37168680fc080e" "bda522415d37bc8f18b60acad3ac5b9382764f68")
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "c1fa41175af84710f4a22f81faab420dcbb774c5")
CROS_WORKON_PROJECT=("chromiumos/platform2" "chromiumos/platform/tast-tests")
CROS_WORKON_LOCALNAME=("platform2" "platform/tast-tests")
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/tast-tests")
CROS_WORKON_SUBTREE=("common-mk .gn" "helpers")
PLATFORM_SUBDIR="tast-tests/helpers/local"
inherit cros-workon platform
DESCRIPTION="Compiled executables used by local Tast tests in the cros bundle"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/+/master/helpers"
LICENSE="BSD-Google GPL-3"
SLOT="0/0"
KEYWORDS="*"
COMMON_DEPEND="
dev-cpp/gtest:=
media-libs/minigbm:=
x11-libs/libdrm:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${RDEPEND}"
src_install() {
# Executable files' names take the form <category>.<TestName>.<bin_name>.
exeinto /usr/libexec/tast/helpers/local/cros
doexe "${OUT}"/*.[A-Z]*.*
# Install symbol list file to the location required by minidump_stackwalk.
# See https://www.chromium.org/developers/decoding-crash-dumps for details.
local crasher_exec="${OUT}/platform.UserCrash.crasher"
local id=$(head -n1 "${crasher_exec}.sym" | cut -d' ' -f 4)
insinto "/usr/libexec/tast/helpers/local/cros/symbols/${crasher_exec##*/}/${id}"
doins "${crasher_exec}.sym"
}