| # Copyright 2018 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk arc/vm/mojo_proxy .gn" |
| |
| PLATFORM_SUBDIR="arc/vm/mojo_proxy" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="ARCVM mojo proxy." |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/vm/mojo_proxy" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| |
| # This package was renamed from arcvm-vsock-proxy. Put a blocker to uninstall |
| # the old package. |
| # TODO(hashimoto): Remove this blocker later. |
| RDEPEND=" |
| !chromeos-base/arcvm-vsock-proxy |
| |
| dev-libs/protobuf:= |
| sys-fs/fuse |
| " |
| |
| DEPEND=" |
| ${RDEPEND} |
| " |
| |
| src_install() { |
| newbin "${OUT}"/server_proxy arcvm_server_proxy |
| |
| insinto /etc/init |
| doins init/arcvm-server-proxy.conf |
| } |
| |
| platform_pkg_test() { |
| platform_test "run" "${OUT}/mojo_proxy_test" |
| } |