blob: 92e4acf279fe33879f5ff71ce35bb7f0e2b25c94 [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="3dcdecbe2315284d385e16c75b81ab34296df50c"
CROS_WORKON_TREE=("5f078a2eb960dbcc4347e114f6f6c4c4e946917e" "e8a783b4b91b58ff2c7d33d09fc6ab656ae8fb0d" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk debugd .gn"
PLATFORM_SUBDIR="debugd/client"
inherit cros-workon platform
DESCRIPTION="Chrome OS debugd client library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/debugd/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "debugd"
}